• Hallo zusammen. Nach dem Forumsupdate gibt es wieder einen Feedbackthread. Bitte nutzt ihn. Die Suchfunktion funktioniert auch wieder :)

Erstellung einer FAQ

Morywen

Senior Member
Registriert
18.10.17
Beiträge
1.021
Jetzt eine dumme Frage, weil ich die Beamdog Version nie gesehen habe. Es gibt BG1 EE und Siege of Dragonspear Castle, was BG1 enthält, hast du beides installiert und wenn ja, gibt es einen oder zwei Ordner? Möglicherweise wird die EET auf den falschen verwiesen. Das ist aber nur eine unqualifizierte Vermutung von mir.
 

Morywen

Senior Member
Registriert
18.10.17
Beiträge
1.021
Und noch eine Frage, versuchst du im Moment von Hand zu installieren? @Maus hat auch recht, eigentlich müsste so eine Meldung kommen, dass die EET das BG ee Directory gefunden hat und ob das richtig ist.
Wenn du über das Tool installierst, sollte es dich in der ersten Maske nach den entsprechenden Verzeichnissen gefragt haben, weswegen ich drauf komme, dass es eventuell einen zweiten Beamdog Ordner mit SoD gibt.
 

Jastey

Matron Modderholic
Registriert
16.05.04
Beiträge
8.039
"00783" ist die BGII:EE @Maus das passt soweit. EDIT: und "00806" ist die SoD.
Die Fehlermeldung sagt leider nichts darüber aus, warum die Installation abgebrochen wird.
 

Frankenheiner

Senior Member
Registriert
13.12.18
Beiträge
226
Richtig. Es wird, nach dem ich das tool nachmals installiert habe, nach den Sprachen gefragt und dann ob der gefundene Ordner der richtige ist. Wenn ich dies bestätige kommt eine Fehlermeldung. Bin mir nicht sicher ob es die gleiche ist wie die die ich schon gepostet habe. ABER! Um so länger ich über das alles grübele (wovon ich eh nur die Hälfte verstehe) bin ich mir nicht mehr 100%ig sicher was als gefundener Pfad/Ordner angezeigt wird. Kann sein das es BG1 EE unter C:\ als gefunden anzeigt, aber tatsächlich habe ich es ja unter D:\
Insgesamt sind es 3 Ordner. BG1EE, BG2EE und SOD. Nummern habe ich nicht im Kopf und im Moment habe ich keinen Zugriff da ich in der Arbeit bin.
Ich komme mir vor wie ein blinder Angler der im trüben Gewässern fischt...ohne Angel und sich wundert warum er nichts fängt....:c:
 

Morywen

Senior Member
Registriert
18.10.17
Beiträge
1.021
@Jastey Danke, da lag ich schon mal falsch. War nur so ein Gedanke.
Ich glaube, ich habe im Forum der extended world den Fehler gefunden. Die EET verwendet regulär die 64 bit Variante der WeiDu. Wenn aber ein 32bit System vorliegt, gibt es die unter Win10 überhaupt noch?, kann es zu dieser Fehlermeldung kommen. Man müsste dann die 32bit Version der WeiDu herunterladen und die .exes mit dieser Version "updaten", damit die EET und andere Mods installiert werden können
 

Frankenheiner

Senior Member
Registriert
13.12.18
Beiträge
226
Und noch eine Frage, versuchst du im Moment von Hand zu installieren?
Ähm, wie sollte ich anders vorgehen? Ich dachte so eine Installation mit dem PI z.B. sollte ein Kinderspiel sein...:c:

@Jastey Danke, da lag ich schon mal falsch. War nur so ein Gedanke.
Ich glaube, ich habe im Forum der extended world den Fehler gefunden. Die EET verwendet regulär die 64 bit Variante der WeiDu. Wenn aber ein 32bit System vorliegt, gibt es die unter Win10 überhaupt noch?, kann es zu dieser Fehlermeldung kommen. Man müsste dann die 32bit Version der WeiDu herunterladen und die .exes mit dieser Version "updaten", damit die EET und andere Mods installiert werden können
Jetzt haut´s mir den Vogel ganz raus...Hilfe! Ich werde später schauen was für eine Version mein Laptop hat
 

Morywen

Senior Member
Registriert
18.10.17
Beiträge
1.021
@Frankenheiner Na ja, Kinderspiel ist beim BG Modding immer so eine Sache, das PI ist ja noch im Betazustand. Möglicherweise lässt es sich auch nicht auf deinem Laptop installieren, weil dieser ein 32 bit System beinhaltet, da müsste ich aber noch mal nachlesen, was Alien so schreibt. Wenn du das Setuptool von Roxanne verwendest, sollte dieses die WeiDu an das System anpassen, behauptet zumindest Roxanne, es scheint nur manchmal fehlzuschlagen. Ich würde mit dem Tool keine NPCs installieren und auch bei Quests schauen, dass es die Originalversionen herunterlädt. Bei Tweaks fummelt sie nicht herum, weswegen es für eine Installation für einen Solorun durchaus zu gebrauchen wäre.
Ich habe direkt nachgesehen, dein Laptop muss ein 32bit System sein, deswegen läuft das PI nicht. Dazu benötigt man ein 64bit System mit Win7/8/10 auf neuestem Stand. DIe Informationen zu deinem Rechner findest du, wenn du auf das Windowsymbol (Start) am linken Rand klickst, dann auf Einstellungen, System, Info. Da werden dir alle Angaben zum System gemacht.
Die neueste WeiDu findest du hier:
https://github.com/WeiDUorg/weidu/releases/tag/v246.00, die 32 bit exe befindet sich unter bin/x86
 

Frankenheiner

Senior Member
Registriert
13.12.18
Beiträge
226
@Morywen
Erstmal 1000 Dank für deine, eure!, Geduld mit mir.
Da mir mein Laptop das PI verbietet, werde ich mit dem Setuptool mein Glück versuchen. Wie du richtig geschrieben hast werde ich nur solo unterwegs sein und nur die Tweak Anthology installiere , Stichwort xp cap.
Ich werde heute Abend schauen was mein Laptop für eine Version ist.

Habe ich also mit einer 32bit Version trotzdem eine Chance auf meine EET?

@Frankenheiner
Die neueste WeiDu findest du hier:
https://github.com/WeiDUorg/weidu/releases/tag/v246.00, die 32 bit exe befindet sich unter bin/x86
...werde erst am Sonntag dazu kommen mich in Ruhe damit zu befassen. Danke!
 

Morywen

Senior Member
Registriert
18.10.17
Beiträge
1.021
Das Grundspiel ist so alt, dass es auch mit einem 32Bit System keine Probleme geben sollte. Man muss das halt nur wissen. Mir war das auch nicht klar, und ich musste erstmal nachlesen. Wenn du die Windows zip herunterlädst und entpackst, findest du in dem Ordner bin die gewünschte Version. Wenn du nur die EET und die Tweak Anthology installieren willst, ist das Tool relativ unproblematisch. Bei zwei Mods, kann man natürlich auch von Hand installieren.
Ich habe mal in die Beschreibungen im ersten Post dieses Threads eine Warnung geschrieben, was die WeiDu angeht. So findet man immer wieder Probleme, die man so nicht auf dem Schirm hat.
 

Dabus

Senior Member
Registriert
18.11.07
Beiträge
5.065
Öhm, das Du PI ausführen kannst, obwohl Windows "dagegen" ist, weißt Du aber, richtig?
Im Englischen sieht der Weg sonst so aus: Klick
 

Morywen

Senior Member
Registriert
18.10.17
Beiträge
1.021
@Dabus in diesem Fall will das PI nicht mit seinem Windows reden. Alien hat es für die 64 Bit Version geschrieben, und es spricht wohl nicht mit den älteren 32er Versionen. Ich hätte dies auch nicht erwartet, kann es auch nicht testen, weil ich kein lauffähiges 32 Bit System habe. Aber Alien schreibt ausdrücklich 64 System Win7/8/10 auf neuestem Stand.
 

Frankenheiner

Senior Member
Registriert
13.12.18
Beiträge
226
Hab 32bit....

Ich komme trotzdem nicht weiter. Hab diese Datei hier: WeiDU-Windows-246.zip genommen, dann "bin", dann "x86".
Dann kommen 3 Dateien: "tolower", "weidu" und "weinstall", alle im Verzeichnis 00783 BG2EE, richtig?

tolower zeigt mir folgendes:
Do you want to lowercase everything?
(run if you extracted some mods since the last time you ran this utility)
[Y]es or [N]o

weidu zigt dies hier:
[D:\WeiDU-Windows-246\WeiDU-Windows\bin\x86\weidu.exe] WeiDU version 24600
WeiDU (version 24600: "Land of Confusion")
usage: WeiDU [options] BAF,BCS,D,DLG,TRA,TP,TP2-files
General Input Options:
--game X set main game directory to X
--game-by-type X set main game directory to the one where X is installed (BG,BG2,IWD,IWD2,PST)
--nogame do not load any default game files
--search X look in X for input files (cumulative)
--search-ids X look in X for input IDS files (cumulative)
--tlkin X use X as DIALOG.TLK
--ftlkin X use X as DIALOGF.TLK
--use-lang X on games with multiple languages, use files in lang/X/
--tlkmerge X merge X into loaded DIALOG.TLK
Press Enter For More Options

und weinstall zuckt kurz ein Fenster auf, aber das wars dann auch schon...
 

Morywen

Senior Member
Registriert
18.10.17
Beiträge
1.021
Du brauchst nur die WeiDu.exe. Du kopierst diese in das BG2 ee Verzeichnis . Dann schaust du, wie die EET.exe heißt und benennst die weidu.exe in setup-eet.exe um, oder wie sie genau heißt. Dann sollte diese, die 64 bit Variante, kopiere diese am Besten irgendwo anders hin, um Verwechslung zu vermeiden, ersetzen. Danach sollte die eet eigentlich durchlaufen.
 

Frankenheiner

Senior Member
Registriert
13.12.18
Beiträge
226
Kommt wieder folgende Fehlermeldung:
[D:\BeamdogLibrary\00783\setup-eet.exe] WeiDU version 24600
Choose your language:
0 [English]
1 [Polski (Polish)]
2 [Spanish]
3 [French]
4 [Czech]
5 [Russian]
0
Using Language [English]
Please choose the language in which you wish to play the game.
If you later wish to play the game in a different language you will need to edit the file weidu.conf and reinstall your mods.
0 [German]
1 [English]
2 [Spanish]
3 [Italian]
4 [Korean]
5 [Polish]
6 [Russian]
7 [Simplified Chinese]
0
Using .\lang\de_de\dialog.tlk and .\lang\de_de\dialogf.tlk
Would you like to display the readme? [Y]es [N]o
n
Install Component [EET core (resource importation)]?
nstall, or [N]ot Install or [Q]uit? i
Installing [EET core (resource importation)] [1.0 RC12]
INTERACTIVE = 1
LANGUAGE = en_US
argv[0] = %argv[0]%
argv[1] = %argv[1]%
Copying and patching 1 file ...
LANGUAGE_BG2 = de_DE
Creating 1 directory
Copying 1 file ...
Copying and patching 2 files ...
Copying and patching 1 file ...
../00806 directory assigned via EET/bgee_dir.txt
Copying and patching 1 file ...
LANGUAGE_BG1 = en_US
Copying 1 file ...
Copying 1 file ...
Stopping installation because of error.
ERROR Installing [EET core (resource importation)], rolling back to previous state
Will uninstall 2 files for [EET/EET.TP2] component 0.
Uninstalled 2 files for [EET/EET.TP2] component 0.
ERROR: Failure("Uninitialised return value: SYSTEM_ARCH")
PLEASE email the file SETUP-EET.DEBUG to K4thos (swit)
Using Language [English]
Install Component [EET core (resource importation)]?
nstall, or [N]ot Install or [Q]uit?
 

Jastey

Matron Modderholic
Registriert
16.05.04
Beiträge
8.039
ERROR: Failure("Uninitialised return value: SYSTEM_ARCH")
Hm, das könnte langsam etwas für k4thos sein, dass er sich das mal anguckt. EET Forum ist hier bei Gibberlings Three.
Jemand hat diesen Fehler bereits hier einmal gepostet, aber ich sehe keine Lösung. (Himweis: Tips von Jarno kann man in der Regel ignorieren.) :(
Was war nochmal Dein Setting? SoD, BGII:EE von BeamDog, Windows 10 32 bit, hast Dir die 32 bit widu.exe geholt und damit die setup_EET.exe ersetzt?
 

Frankenheiner

Senior Member
Registriert
13.12.18
Beiträge
226
Win10, 32bit, BG 1EE, SoD und BG 2EE von Beamdog.
Ich werde morgen alles nochmals in Ruhe von Grund auf frisch installieren, eher schaff ich es nicht wegen Bereitschaft.

Andere Frage, wenn ich auf einem 64bit System die EET installiere und dann das Ganze auf meinen Laptop ziehe, läuft das dann?

Wenn alles nichts bringt poste ich es dann bei Gibberlings Three.
Danke+schönes WE
 

Morywen

Senior Member
Registriert
18.10.17
Beiträge
1.021
Das Umziehen sollte theoretisch klappen, denn fertig installiert, ist die WeiDu Version uninteressant. Ich habe letztlich eine EET aif einen anderen Laptop verschoben, allerdings waren es beides 64 Bit Systeme. Das Spiel selber hat aber mit 32 keine Schwierigkeiten.
Vielleicht musst du aus dem EET Ordner noch einen Ordner temp löschen. . Leider ist es immer schwierig, weiter zu helfen, wenn man das Problem nicht nachstellen kann. Morgen bin ich leider nicht im der Lage viel ins Forum zu schauen, werde aber versuchen weiter zu helfen.
Ich drücke dir die Daumen.
 

Frankenheiner

Senior Member
Registriert
13.12.18
Beiträge
226
Teilerfolg kann ich vermelden. PI bringe ich auf anderen Rechner zum laufen. Bis zur Mod-Auswahl...das braucht das PI plötzlich ein Programm namens "GIT". Also das Dingens runtergeladen ohne zu wissen warum oder was es macht -> Endstation, da keine Ahnung was ich mit dem Programm anstellen soll. Frage mich warum das PI noch ein extra Programm benötigt?!? Oder was mache ich falsch?

Dann wieder das Tool probiert...bei der Abfrage der BG:EE SoD Installation akzeptiert es meinen Pfad nicht....Ich kopiere den Pfad, also kann doch nichts falsch sein? Habe es mit den Ordner der BG1EE, SoD und BG2EE probiert, angeblich alle ungültig.
 

Dabus

Senior Member
Registriert
18.11.07
Beiträge
5.065
Git ist eigentlich ein Tool, mit dem man Projekte verwalten sollte.
Als X Leute arbeiten an einem großen Batzen Programm-Code in X Dateien und bringen die lokalen Daten auf Ihrem PC dann mit denen auf dem Server in Einklang, bringen da Kommentare an und so weiter und die anderen können dann auf die Änderungen zugreifen / verfolgen und damit weiter arbeiten.

Nun kann man natürlich nicht nur Textformate, sondern alles auf so einen Git-Server laden und weil das gut klappt, haben einige Server ihre Downloads bei Git deponiert.

PI lädt die Informationen, der einzelnen Mods / Bezeichnungen / Download-URLs / usw. dann aus den bekannten Ausgangspunkten für diese Serverseiten (z.B. G3) aus der GIT-Struktur runter. Das macht es alles, damit keiner mehr die Informationen zentral pflegen muss. Das bedeutet natürlich im Umkehrschluss, daß man mit PI auf alle automatischen Downloads / Installationen außer denen auf GIT verzichtet. Bevor Du was bekanntest vermisst - das dürften immer noch einige hundert Mods sein. Wenn man die haben will, muss man selber Hand anlegen. Aber das steht hier ja auch im Thread drin. ;)

Oder zumindest war das bis vor ein paar Monaten noch so der Fall. Wenn PI nun GIT haben will, dürfte er das also für den Download auf den Rechner haben wollen.
 
Oben