[Installation] Widescreen Mod - fehlerhafte Anzeige

Teylor

Member
Registriert
01.06.2008
Beiträge
60
Hallo,

Ich habe gestern die BGT Mod und widescreen Mod installiert nach diesem Guide (Ultimate BG Experience) und musste beim Start leider feststellen, dass im schwarzen Hintergrund und im Textfenster am unteren Rand Fragemente zu sehen sind. Wenn ich mit dem Mauszeiger drüber fahre, bleiben Teile des Mauszeigers in diesen Fragmenten "stecken", was auf Dauer natürlich nicht sehr schön aussieht und die Atmosphäre zerstört. Wenn ich die Mod deinstalliere und irgendeine Auflösung einstelle, dann sieht alles normal aus.

Hier ein paar Beispiel Screens:

Bild1

Bild2


Hat jemand eine Idee, was ich hier machen kann? Die Forumsuche hat bei mir nichts ergeben, wusste aber auch nicht genau, welche Begriffe ich eingeben muss (unter Widescreen jedenfalls nichts gefunden).


Danke und liebe Grüße!

Teylor
 
Zuletzt bearbeitet:

Morywen

Senior Member
Registriert
18.10.2017
Beiträge
1.120
Das klingt nach einem Problem mit den Grafikeinstellungen. Ob das bei einem gemoddeten Spiel zu beheben ist, ist schwer zu sagen.
Wenn du im BGII Ordner die config.exe öffnest, gibt es verschiedene Grafikeinstellungen, nicht nur zu 3d, sondern auch Schatten und ähnliches, da kannst du verschiedene Dinge ausprobieren. Translucent Shadows oder so ähnlich sind häufig eine Fehlerquelle. Es könnte auch an der Einstellung der Wegpunkte liegen. Da muss man leider rumprobieren. Möglicherweise klappt das aber mit einem schon veränderten Spiel nicht mehr, das ist aber selten.
 

Maus

Senior Member
Registriert
07.08.2002
Beiträge
6.765
@Acifer könnte was wissen. Ich meine sowas schon mal gesehen zu haben in gemoddeten Areas und er kannte glaube ich die Lösung.
 

Acifer

Senior Member
Registriert
27.04.2019
Beiträge
897
Puh, da weiß ich leider auch nicht genau, wo der Fehler liegt. Da es sich um die klassische Version handelt, kommt das horizontale-Streifen-Problem der Enhanced Edition leider nicht in Betracht.
Die kleinen Fragmente sind vermutlich die einzelnen Kacheln, die das Spiel erzeugt.
Die klassische Engine funktioniert ja so: Die eigentlichen Grafiken werden in kleine 64x64 Pixel große Häppchen zerteilt, welche im Spiel als Kacheln einzeln geladen werden, um Ressourcen zu sparen. Gegebenenfalls hat bei Dir die Engine Probleme, die vielen Kacheln richtig zu rendern.
Mir fällt nämlich auf, dass die Auflösung, die Du gewählt hast, mit 3440 x 1440 extrem hoch ist. Da gab es bei mir auch einmal Probleme - zusätzlich auch, weil das Seitenverhältnis nicht dem des ursprünglichen Spieles entsprochen hat.

Ich würde Dir daher raten, im Widescreen-Mod die Auflösung drastisch zu reduzieren.
Ich spiele in 1600x1200, obwohl mein Bildschirm eine native Auflösung von 3840x2160 hergeben würde, und das Spiel sieht trotzdem schön aus. Eine höhere Auflösung hat bei mir nicht funktioniert, weil ich auch Artefakte hatte. Diese sahen zwar anders aus als diejenigen, die Du beschreibst, aber ich vermute wirklich stark, dass es an der Auflösung liegen könnte.
 

Teylor

Member
Registriert
01.06.2008
Beiträge
60
Puh, da weiß ich leider auch nicht genau, wo der Fehler liegt. Da es sich um die klassische Version handelt, kommt das horizontale-Streifen-Problem der Enhanced Edition leider nicht in Betracht.
Die kleinen Fragmente sind vermutlich die einzelnen Kacheln, die das Spiel erzeugt.
Die klassische Engine funktioniert ja so: Die eigentlichen Grafiken werden in kleine 64x64 Pixel große Häppchen zerteilt, welche im Spiel als Kacheln einzeln geladen werden, um Ressourcen zu sparen. Gegebenenfalls hat bei Dir die Engine Probleme, die vielen Kacheln richtig zu rendern.
Mir fällt nämlich auf, dass die Auflösung, die Du gewählt hast, mit 3440 x 1440 extrem hoch ist. Da gab es bei mir auch einmal Probleme - zusätzlich auch, weil das Seitenverhältnis nicht dem des ursprünglichen Spieles entsprochen hat.

Ich würde Dir daher raten, im Widescreen-Mod die Auflösung drastisch zu reduzieren.
Ich spiele in 1600x1200, obwohl mein Bildschirm eine native Auflösung von 3840x2160 hergeben würde, und das Spiel sieht trotzdem schön aus. Eine höhere Auflösung hat bei mir nicht funktioniert, weil ich auch Artefakte hatte. Diese sahen zwar anders aus als diejenigen, die Du beschreibst, aber ich vermute wirklich stark, dass es an der Auflösung liegen könnte.

Hab jetzt 1600x1200 ausprobiert und habe leider genau das Selbe Problem wie vorher auch.

Hab jetzt Widescreen auch nochmal deaktiviert und sehe doch, dass das Problem weiterhin besteht. Man erkennt überall Linien und im Schwarzen Bereich sehr deutlich. Hab auch die Konfiguration komplett verändert und sehe keine Veränderung.

Hilfe :(
 

Maus

Senior Member
Registriert
07.08.2002
Beiträge
6.765
In dem Installationsleitfaden sind Graphics Overhaul und 1pp drin. Das ergibt natürlich jede Menge mögliche Probleme. Vor allem ist die Anleitung von 2013. Da dürften einige Mods inzwischen ein Update erfahren haben und sind möglicherweise gerade im graphischen Bereich nicht so kompatibel. Das könnte die Ursache für das Problem sein.

Grafik ist halt nicht so meine Expertise ;)
 

Morywen

Senior Member
Registriert
18.10.2017
Beiträge
1.120
Ich glaube nicht, dass eine Mod schuld ist. Ich kenne diese Artefakte in BG 2. Bei neueren Grafikkarten tritt das auch ungemoddet auf. Zum Teil hatte ich frisch installiert Bildfehler und Mausflimmern, das eine Bedienung praktisch unmöglich machte. Je nach Laptop musste ich andere Einstellungen nehmen, um ein sauberes Bild zu kriegen. Ich befürchte nur, wenn der Fehler nicht zu beheben ist, könnte es nötig sein neu aufzusetzen. Gerade wenn Graphic Overhaul installiert ist.
Wenn du dir die Arbeit machen willst, würde ich das Vanilla starten und schauen, ob die Fehler schon da sind. Dann kannst du in der bgconfig raumprobieren, was geändert werden muss. Ich habe die möglichen Kandidaten nicht im Kopf. Ich kann morgen erst nachsehen, was sinnvoll ist auszuprobieren. Ansonsten mal Googeln im englischen Foren finden sich vielleicht Tipps.
 

Teylor

Member
Registriert
01.06.2008
Beiträge
60
Ich hatte mir zum Glück BackUps von den Vanilla Versionen gemacht, für den Fall, dass ich neu aufsetzen muss.

In der Vanilla Version habe ich die Probleme tatsächlich nicht.

Hat jemand einen aktuelleren Guide für eine Megamod Installation nach BGT oder ähnlichem? Danke euch bisher!

LG
 

Morywen

Senior Member
Registriert
18.10.2017
Beiträge
1.120
Das ist interessant. Hast du bei Graphic Overhaul beide Punkte installiert? Ich meine mich zu erinnern, dass es da Probleme geben kann.
Ansonsten würde ich die PDF zum BigWorldProject empfehlen. Wenn es hier nicht in den Ressourcen ist, ist es bei ShS zu finden. Ansonsten gab es hier im Forum eine Diskussion über Installationsreihenfolgen und einen FAQ Thread.
 

Teylor

Member
Registriert
01.06.2008
Beiträge
60
Ich hatte das mit BWP probiert, aber irgendwie kam ich über den Anfang nicht hinaus. Hab BWS nicht dazu bekommen, Mods für mich zu downloaden. Angeblich hat irgendein Downloadordner für BWP gefehlt. Bin nicht ganz durchgestiegen, trotz PDF. :(
 

Maus

Senior Member
Registriert
07.08.2002
Beiträge
6.765
BWP würde ich auch nicht mehr nehmen. Entweder BGT oder Project Infinity. Aber ich kenn mich da nicht so ganz aus, weil ich halt die EE-Versionen habe und daher mit der EET unterwegs bin.
 

Teylor

Member
Registriert
01.06.2008
Beiträge
60
Ja BWP wird meines Wissens ja auch nicht mehr unterstützt bzw. weiter entwickelt. Daher hatte ich mich an BGT gewandt und die Installation lief auch super. Nur für Grafikfehler Nerven doch sehr... ☹️
 

Morywen

Senior Member
Registriert
18.10.2017
Beiträge
1.120
So als kleine Verständniserklärung, die BGT ist die Mod, die BG und BGII zu einem großen Spiel zusammenfasst. Die BWP wird von Leonardo Watson herausgegeben und aktualisiert, wie er Zeit findet. Da muss man die gewünschten Mods in den Ordner BWPDownloads oder so werfen und dieser muss in gleichen Verzeichnis liegen wie BG und BG II. Dort kann man zwischen verschiedenen vorgefertigten Kompilations wählen oder sich durch die individual.bat arbeiten. Da hier batch Dateien verwenden werden, sollte man in dem Verzeichnis Adminrechte haben und am Besten den Sicherheitsapparat von Windows sagen, er soll sich aus dem Ordner raushalten. Dann funktioniert es gewöhnlich ganz gut.
Die BWS ist aus der BWP entstanden, die Auswahl war komfortabeler und die Mods wurden automatisch heruntergeladen. Da dieses Tool seit mehreren Jahren nicht mehr betreut wird, ist es für eine Installation inzwischen ungeeignet. Beim Project Infinity muss man die Installationsreihenfolge selbst erstellen.
Wenn du dein WeiDulog posten würdest, könnte das helfen, den Übeltäter zu identifizieren. Bei Grafikfehlern bin ich auch kein Experte, aber manchmal findet ja auch ein blindes Huhn ein Korn.
 

Teylor

Member
Registriert
01.06.2008
Beiträge
60
Ich werde es nochmal neu aufsetzen und schauen, nach welcher Mod der Fehler entsteht. Da ich mittlerweile die Grafikmods deinstalliert und wieder installiert habe, hat es mir vermutlich sowieso mein BGT zerschossen.
 

Teylor

Member
Registriert
01.06.2008
Beiträge
60
Also ich weiß jetzt woran es liegt.

In der Konfiguration kann man 3D an und ausschalten. Sobald ich es anschalte, habe ich die Umrandungen wie in den obigen Screenshots. Problem ist: Sobald ich es ausschalte, läuft mein Spiel unglaublich langsam, der Cursor flackert und das Spiel hängt sich schnell auf. Jemand eine Idee?

Edit: Ich habs endlich geschafft! Ich musste die 3D Einstellung aktivieren und dann die baldur.exe der NVIDIA Systemsteuerung bei den 3D Einstellungen hinzufügen und ein paar Veränderungen vornehmen. Nach dem guten Try and Error Prinzip habe ich nun Einstellungen gefunden, in denen das Spiel perfekt angezeigt wird. Nochmal danke an alle! :)
 
Zuletzt bearbeitet:
Oben