[BG2EE] Patch 2.6 ist raus

Jastey

Matron Modderholic
Registriert
16.05.2004
Beiträge
9.458
Der 2.6 Patch für die EE Spiele ist nun offiziell raus. Die wichtigste Änderung ist wohl, das 32-bit Systeme nicht mehr unterstützt werden (eine Änderung, die BeamDog tatsächlich mit den Worten "this improves system compatibility" anpreist...).
Link zur offiziellen Ankündigung im BeamDog-Forum.

Für alle, die eine EET mit dem neuen Patch wagen wollen: morpheus562 hat einen Patch gepostet, mit dem die UI wieder funktioniert. Ansonsten wurde EET noch nicht angepasst. Link hier.

Es wird dauern, bis die Mods daran angepasst sind. Ihr könnt das unterstützen, indem Ihr alles auf die 2.6 installiert, was Euch interessiert, und den Moddern Feedback gebt.

(Leider kann ich nicht posten, ohne ein Präfix zu wählen. Der Patch ist aber für Baldur's Gate, Baldur's Gate II, Siege of Dragonspear und Icewind Dale Enhanced Editions.)
 
Zuletzt bearbeitet:

Maus

Senior Member
Registriert
07.08.2002
Beiträge
7.504
Hunderte von Bugs gefixed und gleich bei Release dann eine längere List mit bekannten Bugs gepostet... sehr vertrauenserweckend... Ich werde denke ich noch lange die 2.5 Quellen behalten und halt noch eine 2.6 zum Testen aufsetzen...
 

Jastey

Matron Modderholic
Registriert
16.05.2004
Beiträge
9.458
Naja, ist ja bei Mods schon so - wenn das Update draußen ist weiß ich am nächsten Tag mindestens noch 3 weitere Bugs, die noch drin sind. Immerhin sieht es so aus, als ob es ihnen bewusst ist - und sie eine 2.7 planen.
 

Maus

Senior Member
Registriert
07.08.2002
Beiträge
7.504
Modder sind aber keine Firmen und haben auch keine Quality Assessment Abteilung oder so ;)
 

Jarl

Senior Member
Registriert
28.04.2006
Beiträge
928
Es wurde schon vor Monaten ausdrücklich drauf hingewiesen, dass das nicht das letzte Update sein würde... Nur zur Info.

Grüße!
Jarl
 

Jastey

Matron Modderholic
Registriert
16.05.2004
Beiträge
9.458

Jastey

Matron Modderholic
Registriert
16.05.2004
Beiträge
9.458
...Was ich gar nicht so spät fände. Ich meine, wir reden hier über die IE-Spiele, in der Bugreports zu Mods zum Teil nach 10 Jahren bearbeitet weden.
 

Jastey

Matron Modderholic
Registriert
16.05.2004
Beiträge
9.458
Für alle, die eine EET mit dem neuen Patch wagen wollen: morpheus562 hat einen Patch gepostet, mit dem die UI wieder funktioniert. Ansonsten wurde EET noch nicht angepasst. Link hier.
 

Danol

Senior Member
Registriert
06.02.2011
Beiträge
506
Die wichtigste Änderung ist wohl, das 32-bit Systeme nicht mehr unterstützt werden (eine Änderung, die BeamDog tatsächlich mit den Worten "this improves system compatibility" anpreist...).

LOL. Ich finds ja gut dass die 32-bit-Systeme langsam in Rente geschickt werden, aber die Beschreibung ist ja nun wirklich komplett daneben.

Die Patchnotes an sich klingen, wie leider so oft bei Beamdog, mal wieder halbgar. Den Geister vom Schamanen sind noch frustrierender geworden und verbesserte Unsichtbarkeit ist noch weniger verbessert als ohnehin schon immer (in den EEs). Sfz. Bei den EE-Patchnotes wünsche ich mir immer einen "Mach alle Beamdog-Änderungen an Klassen, Spells und Items rückgängig"-Mod. Gut, dass ich mit der GoG-Version wenigstens von den Steam-Zwangsupdates verschont bleibe.

Nebenbei gefragt: ist es eigentlich zuviel verlangt, aussagekräftige Patchnotes zu verfassen? "Fixed inconsistencies, casting time and minor issues" heißt nun genau was?
 

Jastey

Matron Modderholic
Registriert
16.05.2004
Beiträge
9.458
ist es eigentlich zuviel verlangt, aussagekräftige Patchnotes zu verfassen?
Tja, da rennst Du bei mir offene Türen ein. Ein ausführliches Changelog zu SoD gibt es - außer ich hab's übersehen - wohl gar nicht, dabei ist das das Spiel, bei dem BeamDog gerne bei Patches alles Mögliche hin- und herschiebt so dass sich auch Referenznummern in Dialogen ändern etc. Meine Anfrage hierzu wird bisher ignoriert. :(
 

Shai Hulud

Member
Registriert
18.01.2015
Beiträge
52
Ein ausführliches Changelog zu SoD gibt es - außer ich hab's übersehen - wohl gar nicht, dabei ist das das Spiel, bei dem BeamDog gerne bei Patches alles Mögliche hin- und herschiebt so dass sich auch Referenznummern in Dialogen ändern etc. Meine Anfrage hierzu wird bisher ignoriert. :(
Ich glaube, ich erinnere mich daran, deinen Post im Beamdog-Forum gesehen zu haben. Kam da tatsächlich nie eine Antwort darauf? Hach, Beamdog … :rolleyes:
 

Jastey

Matron Modderholic
Registriert
16.05.2004
Beiträge
9.458
Ich sehe keine, immer nur für BG:EE (die Liste enthält auch nur Eintragungen für BG1), BGII:EE und IWD:EE, z.B. hier.
Es lässt für mich zwei Schlüsse zu: Sie haben nichts inhaltliches in SoD geändert. Oder es gibt einfach keine Liste darüberm weil es ihr eigenes Spiel ist. Oder so.

Eine direkte Antwort damit ich bescheid weiß wäre trotzdem nett gewesen. Aber nochmal nachfragen in einem Forum, dass für Kritik Warnpunkte verteilt... naja.

EDIT: @Argent hat für die SoD diff files erstellt: hier.
 
Zuletzt bearbeitet:

Morywen

Senior Member
Registriert
18.10.2017
Beiträge
1.495
Was für ein Glück, dass mein Testrechner schon auf 64bit ist. Dann schaue ich Mal bei Gelegenheit, eine Testinstallation abzuwerfen. Wenn jemand Wünsche für zu installierende Mods hat, sagt Bescheid. Ich hoffe RL lässt mir jetzt wieder etwas Zeit.
 

Jastey

Matron Modderholic
Registriert
16.05.2004
Beiträge
9.458
@Morywen das wünsche ich Dir auch!
Mein genereller Vorschlag: jeder nimmt die Mods auf der 2.6 mit, die ihm/ihr am wichtigsten sind. Je mehr konkrete Fehlermeldungen, desto eher gibt es ein Kompatibilitätsupdate.
 

Flomf

Member
Registriert
21.02.2008
Beiträge
33
Moin, eigentlich war ich gerade in einem sehr gedehnten Erstdurchlauf der EE: Siege of Dragonspear mit Breagar als einzigem Mod (den möchte ich einfach nicht mehr missen!). Leider hatte ich in Steam das Auto Update aktiviert, sodass Breagar nun im Spiel nur noch als InvalidChar läuft. Muss ich da jetzt so durch und in BG2: EE läuft dann alles wieder oder muss ich auf ihn verzichten? Falls falscher Thread, gerne verschieben und vielen Dank!
 

Jastey

Matron Modderholic
Registriert
16.05.2004
Beiträge
9.458
Wenn Du getrennte Spiele spielst (also keine EET) und für die BGII die Mod erst installierst dann wird er da als Breagar erscheinen. Allerdings kann ich nicht abschätzen, ob die Mod mit 2.6 kompatibel ist. Fehlermeldungen nehme ich gerne entgegen.
 

Morywen

Senior Member
Registriert
18.10.2017
Beiträge
1.495
Ich bin noch nicht zu einer Installation gekommen, habe deswegen eine Frage. Ist es zurzeit sinnvoll, Kits oder Zauber verändernde Mods zu installieren? RR und Icewindification wären Kandidaten, aber wenn klar ist, dass sie wahrscheinlich nicht funktionieren, würde ich sie zum Testen weglassen.
 
Oben