[Bug] Generalized-biffing Problem

Lumorus

Wachender
Registriert
03.03.2011
Beiträge
3.119
So komisch das auch klingt - und vor allem ist:
Nachdem ich schon vorgestern versuchte, eine neue BGT-Installation zu machen, stellte sich heraus, dass das Spiel immer dann abstürzt, sobald die Charaktererschaffung/Importierung eines HC beendet ist und das eigentliche Spiel beginnt. Als Fehlermeldung heißt es dann nur, dass BG2 Exe nicht mehr funktioniert ...
Das komische ist, dass ich vorher noch nie Probleme damit hatte - ich hatte die generalized-biffing-v2.3 Mod schon ein paar mal benutzt und gab dieses Problem nie ... Ich habe es dann auch mit der aktuellen generalized-biffing-v2.4 versucht - da ist es das gleiche.

Weiss jemand, woher das plötzlich kommen kann, bzw, wie es behoben werden kann?

Sollte es keine Lösung dafür geben, hoffe ich, dass es eine andere Lösung gibt, Lags in BGT zu beheben - selbst bei meiner kleinen Installaton, die ich seit gestern habe, lagt es an einigen Stellen ziemlich.
 

Acifer

Senior Member
Registriert
27.04.2019
Beiträge
1.080
Weiss jemand, woher das plötzlich kommen kann, bzw, wie es behoben werden kann?
Hast Du 1pp installiert? Dann stürzt das Spiel bei mir ab, wenn ein Charakter importiert wird und man das Spiel danach z.B. speichern möchte.

Probiere probeweise einmal, die ganz normale Charaktererstellung zu durchlaufen, also einen von Grund auf neuen Charakter zu erstellen.
Wenn der Fehler dann noch auftritt, liegt es leider an etwas anderem...
 

Lumorus

Wachender
Registriert
03.03.2011
Beiträge
3.119
Hast Du 1pp installiert? Dann stürzt das Spiel bei mir ab, wenn ein Charakter importiert wird und man das Spiel danach z.B. speichern möchte.
Oh stimmt, das habe ich tatsächlich installiert!

Leider passiert der Absturz auch, wenn ich einen völlig neuen Charakter erstellt habe und das Spiel starte ...

Aber danke für die Spur, @Acifer! :up:Dann versuche ich jetzt nochmal BGT OHNE pp1 zu installieren und schaue, ob es dann immer noch so ist - ich glaube, die pp1, die ich verwendet habe, ist auch die aktuellste ...
 

Jastey

Matron Modderholic
Registriert
16.05.2004
Beiträge
9.336
Das ist auf alle Fälle was was ich an Gwendolyne weitergebensollte. Ich warte mal, was bei Dir ohne 1pp rauskommt, @Lumorus .
 

Lumorus

Wachender
Registriert
03.03.2011
Beiträge
3.119
Das haut mich jetzt um ...
Ich habe BGT jetzt ohne PP1 installiert - und da gab es das Problem mit generalized-biffing nicht.
Da waren weder pp1 noch Infinite Animations installiert und das Spiel lief.

Dann habe ich generalized-biffing wieder deinstalliert und Infinity Animations installiert - und das Problem war wieder da!
Als ich Infinity Animations wieder deinstalliert hatte, ging es komischerweise wieder ...

Kann es sein, dass generalized-biffing plötzlich Probleme mit Grafik-Mods allgemein haben könnte?
:eek::wunder:
 

Morywen

Senior Member
Registriert
18.10.2017
Beiträge
1.478
Das wäre natürlich schlecht. Nach Weihnachten muss ich das mal ausprobieren.
 

Lumorus

Wachender
Registriert
03.03.2011
Beiträge
3.119
Hm, gibt es zufällig eine Möglichkeit, weidu wieder auf Version 426 zu bekommen? Da lief es, glaube ich noch gut mit Generalized Biffing + Grafikmods ... und ohne GB ist es teilweise ziemlich blöd wegen den Lags ...
 

Morywen

Senior Member
Registriert
18.10.2017
Beiträge
1.478
Du kannst alle setup.mod.exes löschen und auch eine vorhandene weidu.exe löschen. Dann GB hinein kopieren und deren .exe verwenden, die ist noch auf 246.
 

Lumorus

Wachender
Registriert
03.03.2011
Beiträge
3.119
Super, danke für den Tipp, nun läuft es wieder rund!
Meinen Dank an die gute Fee! :)
 

Dabus

Senior Member
Registriert
18.11.2007
Beiträge
5.086
Weidu kann auch einfach am Update gehindert werden, wenn man ihm den Parameter mit gibt.
--noautoupdate do not auto-update WeiDU setup files
Zumindest würde ich es einfacher finden, dafür eine CMD / Powershell / was auch immer auf zu machen als die Setups zu löschen. Aber es führen ja wie man sieht viele Wege nach Rom...
 

Lumorus

Wachender
Registriert
03.03.2011
Beiträge
3.119
@Dabus Oh, das ist gut zu wissen! Vielen Dank! :up:
 

Morywen

Senior Member
Registriert
18.10.2017
Beiträge
1.478
Hm, ich habe probehalber mal IA und 1PP von Hand installiert. Mein Absturz bei der ersten Cutszene kam nicht, wahrscheinlich ist da irgendetwas inkompatibel in der Installation. Jetzt lasse ich mal gb laufen und schaue, was passiert.
 

Morywen

Senior Member
Registriert
18.10.2017
Beiträge
1.478
Absturz nach der Charaktererstellung. GB ist zurzeit nicht mit der 247 anzuraten.
 

Lumorus

Wachender
Registriert
03.03.2011
Beiträge
3.119
Mittlerweile gibt es von GB eine Version 2.5 - in meiner nächsten Installation schaue ich, ob damit das Problem weiterhin besteht.
 

Jastey

Matron Modderholic
Registriert
16.05.2004
Beiträge
9.336
@Lumorus schau ins Changelog der Version, da sollte es drinstehen.
 

Lumorus

Wachender
Registriert
03.03.2011
Beiträge
3.119
Danke für den Hinweis, @Jastey!

Das habe ich gemacht, hier ist das Ergebnis. Sieht aber nicht danach aus, als sei das Problem behoben worden?
Ich habe es mal probeweise installiert - der Absturz kam trotzdem.

Version 2.5 (January 30, 2021)​

  • Added Dynamic Install Syntax in generalized_biffing.ini metadata file to support AL|EN's "Project Infinity".
  • Added Brazilian-Portuguese translation (thanks Felipe).
  • Re-format generalized_biffing-readme-english.html with new SHS readme template.

Version 2.4 (April 13, 2020)​

  • Added missing EE-specific resource types: LUA, MENU, PNG and TTF.
  • EE-specific resource types are only considered for EE games.
  • Sorted resource type list alphabetically.

Version 2.3 (February 24, 2020)​

  • Added generalized_biffing.ini metadata file to support AL|EN's "Project Infinity".
  • Added DESIGNATED numbers and "generalized_biffing_min" and "generalized_biffing_all_files" component LABELS.
  • Replaced READLN actions with SUBCOMPONENTS to support AL|EN's "Project Infinity".
  • Externalized tp2 code into *main_component.tpa* library for more comfortable readability and maintenance.
  • Integrated BWP Fixpack (Argent77's BG:EE compatibility patch).
  • Added README command in tp2.
  • Wrote a new generalized_biffing-readme-english.html readme file.
  • Removed useless backup folder.
  • Updated WeiDU installer to v246.
  • Included Linux and Mac Os X versions in the same package (thanks AL|EN's Infinity Auto Packager tool!).
  • Uploaded mod to official Spellhold Studios GitHub mirror account.
 

Jastey

Matron Modderholic
Registriert
16.05.2004
Beiträge
9.336
Achso - ich hatte das verwenchselt. Das Problem mit GB und Weidu v247 geht tiefer, das muss in WeiDU gefixt werden. (Aber bei z.B. Aran Whitehand wäre der mit WeiDU v247 auftretende Installationsfehler in der Mod behebbar.) Es wird bei GB also dabei bleiben, dass man zur Installation auf die v246 downgradet, bis WeiDU v248 es hoffentlich korrigiert.
 

Lumorus

Wachender
Registriert
03.03.2011
Beiträge
3.119
Oh, gut zu wissen, danke ... dann verwende ich weiterhin die frühere WeiDu
 
Oben