[Tutorial] Erstellung einer FAQ

Morywen

Senior Member
Registriert
18.10.2017
Beiträge
1.661
Interessant, ich muss mir seinen Guide Mal in Ruhe durchlesen.
 

Frankenheiner

Senior Member
Registriert
13.12.2018
Beiträge
470
Gibt es bekannte Probleme mit der neuesten EET-Version (247)?

Ich kann machen was ich will, jedes mal bekomme ich die Meldung "Mit Problemen installiert"?
Starten lässt sich die EET über den erstellten Button, aber es erschient der Startbildschirm von SoA und natürlich dementsprechend auch nur die Auswahl SoA oder ToB.
 

Jastey

Matron Modderholic
Registriert
16.05.2004
Beiträge
10.180
Postest Du die Warnungen mal?
 

Frankenheiner

Senior Member
Registriert
13.12.2018
Beiträge
470
Postest Du die Warnungen mal?
Da geht´s ja schon los....Es werden keine angezeigt. Nur der Hinweis "Mit Problemen installiert"
Haben den ganzen "Verlauf" der Installation durchgesehen, aber keinerlei Hinweise auf Warnungen gefunden.
Ich hoffe, ich komme heute oder spätestens morgen nochmal dazu die EET durchlaufen zu lassen und mache einen Screenshot.
 

Morywen

Senior Member
Registriert
18.10.2017
Beiträge
1.661
@Frankenheiner Ich hatte mal zum Testen eine aufgesetzt, die aber ohne Probleme mit der 247 durchgelaufen ist. Ich hatte diese Meldungen unter 246 auch hin und wieder, aber es gab keine erkennbaren Probleme im Spiel. Ich habe im Moment auf der Testinstallation keine extra UI installiert. Bei mir kommt der Startbildschirm von SoA, aber unten rechts steht Kampagne wählen. Dort erscheinen dann alle möglichen Startpunkte von BG1 angefangen bis Black Pits". Ist das bei dir nicht der Fall? Das würde dafür sprechen, dass die EET nicht funktioniert hat.
Du hast die aktuelle EET 13.4 genommen? Dann wäre die Debug interessant, um zu sehen wo das Problem liegt.
 

Frankenheiner

Senior Member
Registriert
13.12.2018
Beiträge
470
@Morywen
Es kommt der normale SoA Startbildschirm, leider.
Verwendet habe ich Version 13.4
Werde später die Debug posten und mal eine ältere EET Version versuchen
 

Frankenheiner

Senior Member
Registriert
13.12.2018
Beiträge
470
@Morywen
Ich hoffe das:
WeiDU v 24700 Log

B:\00783\setup-EET.exe
version = 24700
[.\chitin.key] loaded, 1145567 bytes
[.\chitin.key] 277 BIFFs, 81243 resources
[.\engine.lua] loaded, 109 bytes
[.\weidu.conf] loaded, 17 bytes
[.\lang\de_de\dialog.tlk] 271693 string entries
[.\lang\de_de\dialogf.tlk] 271693 string entries
Using Language [Deutsch (German)]
[Deutsch (German)] has 6 top-level TRA files
[EET/lang/de_DE/prompts.tra] has 56 translation strings
[EET/lang/de_DE/setup.tra] has 18 translation strings
[EET/lang/de_DE/chapters.tra] has 95 translation strings
[EET/lang/de_DE/dialog.tra] has 37 translation strings
[EET/lang/de_DE/2da.tra] has 55 translation strings
[EET/lang/de_DE/compatibility.tra] has 6 translation strings

Mit .\lang\de_de\dialog.tlk und .\lang\de_de\dialogf.tlk
EET/EET.TP2 6 0 Installed

Komponente [EET core (Ressourcen werden importiert)] installieren?
[R]: Neu installieren, [N]: Nichts aendern, : Deinstallieren, [Q]: Beenden.
Zuerst wird die alte Installation von [EET core (Ressourcen werden importiert)] entfernt ...
uninstall: EET/EET.TP2 0
Will uninstall 14473 files for [EET/EET.TP2] component 0.
Restoring backed-up [EET/backup/0/CHITIN.KEY]
EET/backup/0/CHITIN.KEY copied to CHITIN.KEY, 877618 bytes
[.\CHITIN.KEY] loaded, 877618 bytes
[.\CHITIN.KEY] 189 BIFFs, 62285 resources
Unable to Unlink [EET/temp/patch/spl/ADD_SPELL/SPPR100.SPL]: Unix.Unix_error(20, "unlink", "EET/temp/patch/spl/ADD_SPELL/SPPR100.SPL")
Creating directory [EET/temp/patch/spl/ADD_SPELL]
Unable to Unlink [EET/temp/patch/spl/ADD_SPELL/SPWI100.SPL]: Unix.Unix_error(20, "unlink", "EET/temp/patch/spl/ADD_SPELL/SPWI100.SPL")
Unable to Unlink [EET/temp/patch/spl/ADD_SPELL/SPWI200.SPL]: Unix.Unix_error(20, "unlink", "EET/temp/patch/spl/ADD_SPELL/SPWI200.SPL")
Unable to Unlink [EET/temp/patch/spl/ADD_SPELL/SPWI966.SPL]: Unix.Unix_error(20, "unlink", "EET/temp/patch/spl/ADD_SPELL/SPWI966.SPL")
Unable to Unlink [EET/temp/patch/spl/ADD_SPELL/SPIN100.SPL]: Unix.Unix_error(20, "unlink", "EET/temp/patch/spl/ADD_SPELL/SPIN100.SPL")
Unable to Unlink [EET/temp/patch/spl/ADD_SPELL/SPIN204.SPL]: Unix.Unix_error(20, "unlink", "EET/temp/patch/spl/ADD_SPELL/SPIN204.SPL")
Unable to Unlink [EET/temp/patch/spl/ADD_SPELL/SPIN400.SPL]: Unix.Unix_error(20, "unlink", "EET/temp/patch/spl/ADD_SPELL/SPIN400.SPL")
Unable to Unlink [EET/temp/patch/spl/ADD_SPELL/SPIN401.SPL]: Unix.Unix_error(20, "unlink", "EET/temp/patch/spl/ADD_SPELL/SPIN401.SPL")
Unable to Unlink [EET/temp/patch/spl/ADD_SPELL/SPIN500.SPL]: Unix.Unix_error(20, "unlink", "EET/temp/patch/spl/ADD_SPELL/SPIN500.SPL")
Unable to Unlink [EET/temp/patch/spl/ADD_SPELL/SPIN501.SPL]: Unix.Unix_error(20, "unlink", "EET/temp/patch/spl/ADD_SPELL/SPIN501.SPL")
Unable to Unlink [EET/temp/patch/spl/ADD_SPELL/SPIN502.SPL]: Unix.Unix_error(20, "unlink", "EET/temp/patch/spl/ADD_SPELL/SPIN502.SPL")
Unable to Unlink [EET/temp/patch/spl/ADD_SPELL/SPIN503.SPL]: Unix.Unix_error(20, "unlink", "EET/temp/patch/spl/ADD_SPELL/SPIN503.SPL")
Unable to Unlink [EET/temp/patch/spl/ADD_SPELL/SPIN504.SPL]: Unix.Unix_error(20, "unlink", "EET/temp/patch/spl/ADD_SPELL/SPIN504.SPL")
Unable to Unlink [EET/temp/patch/spl/ADD_SPELL/SPIN505.SPL]: Unix.Unix_error(20, "unlink", "EET/temp/patch/spl/ADD_SPELL/SPIN505.SPL")
Unable to Unlink [EET/temp/patch/spl/ADD_SPELL/SPCL100.SPL]: Unix.Unix_error(20, "unlink", "EET/temp/patch/spl/ADD_SPELL/SPCL100.SPL")
Restoring backed-up [EET/backup/0/engine.lua]
EET/backup/0/engine.lua copied to engine.lua, 104 bytes
Restoring backed-up [EET/backup/0/pcu_dict.tph]
EET/backup/0/pcu_dict.tph copied to EET/lib/pcu_dict.tph, 89982 bytes
Restoring backed-up [EET/backup/0/daynite.wbm]
EET/backup/0/daynite.wbm copied to movies/daynite.wbm, 2586217 bytes
Restoring backed-up [EET/backup/0/niteday.wbm]
EET/backup/0/niteday.wbm copied to movies/niteday.wbm, 2668595 bytes
Uninstalled 14473 files for [EET/EET.TP2] component 0.
hilft dir/euch weiter. Der ganze Eintrag der Debug hätte jeden Rahmen gesprengt.

Ansonsten noch hier die Meldung am Ende als screenshot:
 

Anhänge

  • Screenshot (6).png
    Screenshot (6).png
    157,4 KB · Aufrufe: 8

Jastey

Matron Modderholic
Registriert
16.05.2004
Beiträge
10.180
@Frankenheiner danke, sagt mir leider wenig. Kannst Du /würdest Du das mit weidu v246 nachstellen?
 

Maus

Senior Member
Registriert
07.08.2002
Beiträge
8.146
Das ist irgendwas aber mal komplett falsch gelaufen. Platt machen und neu installieren. Und beim nächsten Versuch sich mal sklavisch an Morywens Anleitung halten (nicht alles dabei muss man zwingend machen, aber wenn man sich an alles hält, dann ist es eigentlich ne ziemlich sichere Sache).
 

Frankenheiner

Senior Member
Registriert
13.12.2018
Beiträge
470
@Maus
Habe ich eigentlich. Oder gibt es etwas was ich beachten muss, wenn ich eine alte EET vom Rechner schmeiße und eine neue installieren will? Vielleicht Dinge, die ich noch von Hand löschen muss, sollte?
 

Frankenheiner

Senior Member
Registriert
13.12.2018
Beiträge
470
@Frankenheiner danke, sagt mir leider wenig. Kannst Du /würdest Du das mit weidu v246 nachstellen?
@Jastey
Bin wieder mal mit meinem Latein am Ende. Ich hab dich falsch verstanden, bzw. falsch gelesen. Denn ich wollte die Installation mit einer älteren EET Version versuchen. Hab jetzt zwar die WeiDU v246, aber natürlich 0 Ahnung was ich damit anstellen soll :wunder:
Sorry, aber ich habe einfach zu wenig Wissen oder bin einfach zu blöd
 

Maus

Senior Member
Registriert
07.08.2002
Beiträge
8.146
Wirklich alles neu machen. Die Quellen neu einspielen (oder halt neu kopieren, wenn unbearbeitete Originale auf dem Rechner liegen), die BG1 neu mit den BG1 Mods installieren. Gleich die compatibiliy.tpa editieren und nicht erst die EET anstoßen und dann die Installation wiederholen. Die *.lua vorher editieren etc. Neue Pfade setzen, damit keine alten Dateien aufgerufen werden etc.
Sind alles Dinge, ohne die es auch gerne funktioniert. Aber im Zweifel halt trotzdem alles machen.
Klick-Fehler vermeiden. Lieber langsam machen (ist schwer, I know) und kurz überlegen, ob man nicht was vergessen hat. Oder halt Checkliste vorher schreiben und abarbeiten.
Und was da noch nicht bei Morywen steht: die nicht mehr benötigten setup-xxx.exe löschen. Ich würde auch alles, was nicht mind. weidu 246 ist, ersetzen. Namen kopieren, Datei löschen, weidu-Kopie Namen abändern und mit Strg+v ersetzen.
 

Morywen

Senior Member
Registriert
18.10.2017
Beiträge
1.661
Eine alte Installation sollte kein Problem sein. Du musst nur die neue Installation in einem anderen Ordner anlegen und auch auf die neue BG 1 Installation verweisen. Wichtig ist: Wenn die Installation aus welchen Gründen auch immer nicht funktioniert, alles aus dem Ordner löschen und dann eine "jungfräuliche" BG 2 EE reinkopieren. Ich habe zu diesem Zweck BG2 und BG1 für EEs in den Versionen 2.5 und 2.6 auf der Festplatte liegen. Deinstallation einzelner Mods ist meist kein Problem. Aber die Verschmelzung von beiden Spielen muss man immer wegschmeißen.
 

Jastey

Matron Modderholic
Registriert
16.05.2004
Beiträge
10.180
Wird die EET mit weidu v247 gepackt? Wenn ja, dann ist mein Vorschlag, die v246 zu nehmen hinfällig. Ich dachte bishr, dass EET mit der v246 kommt. Die weidu v247 macht bei manchen Mods Probleme, weil sie irgendwas anders einliest (z.B. gehen Mods, die die Versionsnummer in die tra-Dateien ausgelagert haben, mit v247 nicht.)
@Frankenheiner weidu v246 statt der 247 zu nehmen heißt, wirklich alle setup.exes und weidu.exe aus dem EET-Ordner zu löschen und sicherzugehen, dass die setup-eet.exe v246 ist vor dem Installieren. Wie gesagt, ist nur sinnvoll, wenn EET nicht sowieso mit v247 kommt - denn das wurde ja bereits von anderen dann verwendet.
 

Frankenheiner

Senior Member
Registriert
13.12.2018
Beiträge
470
Ich habe "Jungfräuliche EEs" auf einer externen Festplatte, welche ich erst nachdem ich meine EET komplett vom Verzeichnis gelöscht habe wieder rüberkopiert hab, vorher noch unter C:\user.....alles gelöscht, also Saves, Potraits, usw.
Dann angespielt, Spielstände gespeichert, .lua editiert und dann mit mods unter BG1/SoD angefangen, schließlich EET core unter BG2 laufen lassen, dann kommt die entsprechende Fehlermeldung...
 

Morywen

Senior Member
Registriert
18.10.2017
Beiträge
1.661
@Maus Warum die setup.exes löschen? Die stören doch nicht weiter. WeiDu unter 246 ersetzen, ist sicher eine gute Idee. Da ich größer Installationen nicht mehr von Hand mache, hatte ich das mit dem Autoupdate und seinen Tücken nicht mehr so auf dem Schirm.
 

Morywen

Senior Member
Registriert
18.10.2017
Beiträge
1.661
@Frankenheiner Ich würde Mal entweder die weidu.exe 246 oder 247 nehmen, und sie in setup-EET.exe (schau ob ich es richtig geschrieben habe) umbenennen und dann schauen, ob es dann funktioniert. Entweder ist nämlich die entsprechende Setup.exe kaputt, oder irgendeine andere Datei.
Laut der WeiDu Debug fand die EET noch eine alte Installation.
 

Frankenheiner

Senior Member
Registriert
13.12.2018
Beiträge
470
Da auch eine ältere EET Version das gleiche Ergebnis "Mit Warnungen installiert" brachte, habe ich eine andere Frage:
Wäre es möglich eine andere, funktionierende EET zu verwenden und "einfach" mods entsprechend zu deinstallieren und neue zu installieren?
 
Oben